Browser-Kompatibilität

Plone unterstützt den Zugang zu den Web-Seiten für alle aktuellen Browser. Für standardkompatible Browser bietet Plone zusätzlich vier verschiedene Stufen der Unterstützung an.

Die vier Ebenen der Browser-Unterstützung

  1. Zugang zu den Informationen

    Browser-Anforderungen

    Parsen von (X)HTML

    Funktionen

    Alle Informationen und Funktionen sind zugänglich

  2. Graphische Gestaltung

    Browser-Anforderungen

    CSS2-Unterstützung

    Funktionen

    Plones visuelles Erscheinungsbild

  3. Zusätzliche UI-Unterstützung

    Browser-Anforderungen

    Grundelgende DOM2-Unterstützung

    Funktionen

    Menüs, Datum-Widget

  4. Fortgeschrittene UI-Funktionen

    Browser-Anforderungen

    Vollständige DOM2-Unterstützung, XmlHttpRequest, contentEditable/Midas.

    Funktionen

    Visueller Editor für die Inhalte

Erweiterungen von Plone wie die Integration von GoogleMaps und Videos können davon abweichende Anforderungen haben.

Browser-Liste

spezifiziert, welche Browser zu welcher Ebene kompatibel sind.

  1. Zugang zu den Informationen
    • Text-Browsers wie lynx und w3m.
    • Screen-Reader etc.
  1. Fortgeschrittene UI-Funktionen
    • Internet Explorer 9.0 und höher
    • Firefox: 13.0 und höher
    • Opera 11 und höher
    • Safari 5.0 und höher
    • Chrome 19 und höher